Hummingbird House The Garden Helper
No-dash-here, you've found The Real Garden Helper! Gardening on the Web since 1997
vine bar
Wild Willy
 

bugs on my plant

Gardening Reference » Gardening in 2005
« Prev thread: Bugs on my mums| Next thread: Bugs or Other? »
Back to Thread index
by hinda on August 28, 2005 03:19 PM
a coupld of weeks ago my mil gave me a plant (sorry have no idea what kind..) to try and save - it had been left unwatered for 5 weeks while she was out of the country. i took it home and after a few days it satred new growth. but now i noticed that there is some sort of bug on it. it looks a little like a spider or head lice and is green but they seem to die on their own since i have also found a bunch of them around and on the plant that have turned white. how can i get trid of tehm or do i have to throw out the plant altogether. luckily it is not near any other plants so it hasnt spread anyone else (yet [scaredy] )
thanks [muggs]
by Bids on August 31, 2005 03:13 AM
aphids?

Could u send a pic?

* * * *
Lack of space never stopped a serious gardener.
by Shani on September 03, 2005 01:23 PM
I've had a similar proble with an Aloe of mine and I soaped it. I took regular dishe soap and mixed it with water in a spray bottle and misted the whole plant. I let it sit for a little while and then rinsed it with clean water and wiped down the leaves. It took a while to complete this process but the bugs went away.

* * * *
Shani
 -
May the wind always be at your back
and your keel in the water

Active Garden Forum

« Prev thread: Bugs on my mums| Next thread: Bugs or Other? »
Back to Thread index
Similar discussions:

Other articles you might like: